Missing data between waveform buffers

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
ivinnykov
Newbie
Posts: 0
Joined: Sun Mar 21, 2021 12:48 pm

Missing data between waveform buffers

Post by ivinnykov »

I need to capture and analyze digital signal, so I configured PicoScope and captured data. Once the required signal displayed and pressed the Stop Capturing button so analyze data. But there is a problem. At the end of waveform #11 there is 0V signal:
4.png
If I open the next waveform #12 I can see that the signal starts from 5V and the transition from 0V to 5V is missing:
5.png
Note that there is no zooming and I can see entire waveform on each screen.

The same problem happens in other cases. I captured a a long digital signal that is represented on multiple waveform buffers. I need to know the duration of each state to detect logical 0 and 1, but it is impossible at the start of waveform buffer because some data seems to be lost.

Is it a bug or did I miss something?

Ideally it will be great to capture data during some time and see all data on a single chart with the horizontal scrolling rather than represented on different screens. Is it possible to represent data on a single chart?

Gerry
PICO STAFF
PICO STAFF
Posts: 947
Joined: Mon Aug 11, 2014 11:14 am

Re: Missing data between waveform buffers

Post by Gerry »

Hi ivinnykov,

It's not a bug, it's partly to do with the way you are using it, and partly to do with the physical limitations of capturing data.

You may be used to capturing data in a Data Logger, where you just start the capture, and then leave the data logger to just constantly acquire the data and store it as it is being captured (as this is what you seem to be expecting to happen). Data Loggers can do this because the rate at which they capture the data is slow enough to store in real-time (and even write to a file as it is being sent to the computer). PicoScopes can use this method (but only to write the data to memory), only when capturing the data with Slow sample rates (i.e. in what is known as 'Slow Sample' Mode for our PicoScope 6 software). In PicoScope 6, to use Slow Sampling, the Timebase you set for the capture must be no faster than 100ms/div.

As you were using a Timebase of 2ms/div, you would have been using 'Fast Sample Mode' to capture your data, which means that every capture you performed would have been based upon a Trigger. Even though you were using the default Trigger Mode of 'No Trigger', the software was creating and using an Auto-Trigger that fires every 2 seconds, to capture each block of data. Unfortunately, when capturing repeated blocks of data, there will be gaps between consecutive waveforms. This is because when using 'No Trigger' or a 'Repeat Trigger', an individual buffer of data is captured and then sent to the computer, via USB, before the next block of data can be captured. This data transfer typically takes 10's of milliseconds because of the time that is required to establish a USB connection.

So, this means that ,to capture data without a gap, you need to switch to Slow Sampling, but before you do that, I would suggest enabling the 'Properties Pane' so that you can see all of the important parameters at a glance, in the window on the right of the screen (that way you can follow how parameters are changing as you set different values). You can do this by selecting the Menu options View->View Properties. Make a note of the sample rate you had in 'Fast Sample Mode'.

To switch to Slow Sampling you need to select the 100ms/div Timebase, but you also need to increase the Number of Samples (in the text box to the right of the Timebase) to ensure that you are still using a fast enough Sample Rate (I would just set it to 2GS so that it defaults to the maximum value). So, If you have done all that, and set the Timebase to 100ms/div, you can then start increasing the Timebase until you get a similar sample rate to what you had in 'Fast Sample Mode', and the data quality looks like what you had in the second data file, when you zoom in. At this point you are at the limit of how much data you can capture without any gaps (unless you are happy to reduce the sample rate even further and therefore reduce the quality of the waveforms).
You can perform repeated captures in 'Slow Sample Mode' but there will be gaps in between the repeated captures (because of the housekeeping that the PicoScope has to do before the next Slow Sampling capture). Unfortunately, you can't use it like a Chart Recorder or Data logger if the data is arriving faster than the rate at which it is being transferred over USB and saved.

Regards,

Gerry
Gerry
Technical Specialist

Post Reply