Unable to install drivers on Raspberry 4

Discussion forum for the Picoscope 6 Linux software
Post Reply
Brynog
Newbie
Posts: 0
Joined: Tue Nov 30, 2021 7:57 am

Unable to install drivers on Raspberry 4

Post by Brynog »

Hi,

Not sure if this is where I should post this, but let's see.

I loaded the Picolog software on to my Raspberry Pi 4 (buster). Got it running, ran some tests.

My intent would be to write some custom apps (Python perhaps) because I wish to log at much higher sampling rates.

I ran "sudo apt-get install libps2000a " but it reported "Unable to locate package X".

QUESTION 1:
I had assumed since Picolog was running that the driver package would be available. Is it? If yes, how do I update apt-get to include its location?

QUESTION 2:
What is people's general experience with languages for accessing the API? I'm initially looking at Python or maybe C++. Any pointers or opinions would be helpful.

Regards,
Bryce

Post Reply