Debian Update Fails anyone else?

Discussion forum for the Picoscope 6 Linux software
Post Reply
A.P.
Newbie
Posts: 0
Joined: Mon Oct 25, 2021 9:51 am

Debian Update Fails anyone else?

Post by A.P. »

I've used my PicoScope 2205A successfully on various Linux platforms, Debian Buster, Fedora 34, Slackware and Arch. Recently I have had the Debian update fail:

Upgrade: libpicoipp:amd64 (1.3.0-4r78, 1.3.0-4r121)
Error: Sub-process /usr/bin/dpkg returned an error code (1)

It can be fixed by extracting using "dpkg-deb -R" and making the following change to file /DEBIAN/conffiles
from:
etc/ld.so.conf.d/picoscope.conf

to:
/etc/ld.so.conf.d/picoscope.conf

adding the missing / in front of etc.

Then rebuild the deb package "dpkg-deb -b" and install.

Has any one else had this problem?
Last edited by A.P. on Tue Nov 23, 2021 8:06 am, edited 1 time in total.

Skandia
Newbie
Posts: 0
Joined: Mon Nov 22, 2021 4:14 pm

Re: Debian Update Fails anyone else?

Post by Skandia »

Hi
Yes the update also fails for me on Debian.
If I get some time I will attempt your fix.

Post Reply