No suitable device found

Post any questions you may have about our current range of oscilloscopes
Post Reply
Posts: 0
Joined: Sat Dec 26, 2020 10:13 am

No suitable device found

Post by Edwinner »

My Picoscope 2204A has stopped working. The Picoscope software says: "No suitable device found."
Normally, I am using it on Linux Mint with Picoscope V6.14.44.5870, but it can't recognize it anymore. I installed the latest Picoscope version on a Windows PC as well, but it has the same result. Also PicoLog cannot find the device anymore.

I tried the "usbtest" command which is located in "/opt/picoscope/share/doc/libps2000" and it results in: "Pico USB device not found. Please try again". ( I also tried the usbtest which is located in the libps2000a directory, but it had the same result).

When I try the command "lsusb" with and without the Picoscope connected, I get one additional line when the Picoscope is connected: "Bus 003 Device 017: ID 04b4:8613 Cypress Semiconductor Corp. CY7C68013 EZ-USB FX2 USB 2.0 Development Kit". This means that it does recognize something, but is this correct?

Does anyone have any suggestions how to continue with this?

Post Reply