CAN FD signal decoder

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
GuidoW
Newbie
Posts: 0
Joined: Sun Feb 21, 2021 6:23 am

CAN FD signal decoder

Post by GuidoW »

Hi everybody,

I had some problems decoding CAN FD with ESI state set and BRS activated (4 Mbps).
Assuming BRS is set, the bit duration changes after sample time normally set to app. 81.25 %. The decoding function is doing right if the ESI bit following the BRS bit equals 0. But if not, the decoder is confused and by default evaluates the BRS bit with 100 %! Consequently, the DLC is not calculated correctly and thus the message is not decoded further after only some data bytes.

Or is there any other explanation to solve this? Both messages in the attached screens are exactly the same only difference is the ESI bit.

Thanks and kind regards,
Guido
Attachments
20210312-0001 ESI 1.psdata
(306.29 KiB) Downloaded 32 times
20210312-0001 ESI 0.psdata
(307.51 KiB) Downloaded 31 times
CAN FD ESI 1.jpg
CAN FD ESI 0.jpg

GuidoW
Newbie
Posts: 0
Joined: Sun Feb 21, 2021 6:23 am

Re: CAN FD signal decoder

Post by GuidoW »

Nobody? :?

GuidoW
Newbie
Posts: 0
Joined: Sun Feb 21, 2021 6:23 am

Re: CAN FD signal decoder

Post by GuidoW »

Hi everybody,
sorry - but is there nobody who can help with this issue? Even from the Pico development team?
THANKS AND REGARDS,
Guido

Martyn
Site Admin
Site Admin
Posts: 3977
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CAN FD signal decoder

Post by Martyn »

Sorry for not replying sooner. This looks like it may be a bug, I will need to get someone from the development team to take a look at this. It may take a little while to address due to remote working, and a very busy department.
Martyn
Technical Support Manager

Post Reply