Slackware installation.

Discussion forum for the Picoscope 6 Linux software
Post Reply
Posts: 1
Joined: Thu Jun 28, 2018 11:03 am

Slackware installation.

Post by kimdino »

Hi folks,
Has anyone managed to get a picoscope to run under Slackware? A year ago I bought a PicoScope 2204A and tried installation with no luck. My picoscope has since been gathering dust after I reverted to using a very primitive hardware oscilloscope.

Here are some notes I made at the time for requesting support:-.
" My system is Salix (Slackware 14.2) with KDE as the desktop. This distro comes with a tool, 'rpm2txz', that converts an rpm to a Slackware package. I have used it many times in the past with no problems.

I have downloaded the following files.

I then ran 'rpm2txz libps2000a-1.4.0-5r09.x86_64.rpm' to create the Slackware package 'libps2000a-1.4.0-5r09.x86_64.txz'. I then ran (as root) 'installpkg libps2000a-1.4.0-5r09.x86_64.txz' to install the library package. I then installed the picosope & then picomono packages in the same way. I then added a symlink from '/usr/bin/picoscope' to '/opt/picoscope/bin/picoscope'.

When I tried to run 'picoscope' KDE threw up a momentary message saying something about being unable to find mono. So I then installed 'mono' & 'gtk-sharp 2.12.29' from the Slackware repository.

Now when I try to run 'picoscope' I get the following at the command prompt:-
dino@DeanMachine:~$ picoscope
sg: failed to crypt password with previous salt: Invalid argument

This is the same whether I use my own password, roots or an empty one."

When I try and run 'picoscope' as root I get a startup screen, a very brief glimpse of the main window (captioned 'PicoScope 6 Beta') and a dialogue that says something about 'Update'. The dialogue is gone too quickly to read anymore. The 2204A also has a relay click as the main window appears. Regarding the 'Update' message, I have all the latest versions that I could find on your site.

I have tried cleaning out the installation and doing a fresh install.

Also, I can see nothing installed to udev??? Nothing hapens in the /dev directory when the 'scope is plugged in or unplugged. Assuming it doesn't use mknod, can anyone send me a copy of their picoscope udev script?

I have become frustatated at all the things I cannot do with my crude hardware 'scope and would love to be able to use my picoscope.. Can anyone help?

Cheers, Kevin

Post Reply