PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post your LabVIEW discussions here
Post Reply
seamot
Newbie
Posts: 0
Joined: Wed Sep 18, 2019 4:07 pm

PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post by seamot » Thu Oct 31, 2019 3:50 pm

I am using this Labview example software from https://github.com/picotech/picosdk-ni-labview-examples/tree/master/ps5000a/32-bit-examples. It runs ok and captures the waveforms like I need, but I want the x-axis in the graph to be accurate.
For example, in my screenshot the waveform has 3 periods over about 140 samples. In real life this is about 300ns. My project depends on measuring the time between the peaks, as shown by the peak detector. Any ideas?

Device: PicoScope 5242b
Labview 32 bit
Attachments
zpeakfinder.png
zlabview.png
zlabview.png (11.63 KiB) Viewed 560 times

AndrewA
PICO STAFF
PICO STAFF
Posts: 252
Joined: Tue Oct 21, 2014 3:07 pm

Re: PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post by AndrewA » Mon Nov 04, 2019 11:47 am

Regards Andrew
Technical Specialist

seamot
Newbie
Posts: 0
Joined: Wed Sep 18, 2019 4:07 pm

Re: PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post by seamot » Mon Nov 04, 2019 6:26 pm

Hi,

Thanks for your help. I am unable to start it. I downloaded the new library and the updated program from the links you posted. This is the error message I receive:

PicoErrorHandler2.vi library error message

When I doubleclick on the error message, it goes to this module on PicoErrorHandler2.vi block diagram.

ps2000aCloseUnit

seamot
Newbie
Posts: 0
Joined: Wed Sep 18, 2019 4:07 pm

Re: PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post by seamot » Fri Nov 08, 2019 3:27 pm

I am able to locate the 'missing' node in the dll file. I don't understand why LabView lists it as 'Library not found'?

ps3000.dll

seamot
Newbie
Posts: 0
Joined: Wed Sep 18, 2019 4:07 pm

Re: PicoScope5000aExampleRapidBlockBulk.vi - Convert samples to time?

Post by seamot » Mon Nov 18, 2019 4:48 pm

I think it is solved now. I repaired the 'PicoSDK_32_10.6.13.97' file that can be found on the product downloads page, which seemed to correct the library issues I was having. The screenshot of the signal corresponds to 100 samples. The x axis displays a total signal time of about 300ns.

PicoScope5000aExampleRapidBlockBulk.vi signal output

Post Reply