Picoscope 3403D library - ps3000a.dll crashes inside ps3000aRunBlock API

Post your C and C++ discussions here
Post Reply
Inka
Newbie
Posts: 0
Joined: Tue Apr 16, 2019 3:07 am

Picoscope 3403D library - ps3000a.dll crashes inside ps3000aRunBlock API

Post by Inka » Thu Apr 18, 2019 10:10 am

Hi,
I am using ps3000a.lib in my application with Picoscope 3403D connected to USB2.0 port & AC power.
I can successfully use the device to acquire waveforms.

However, when I repeatedly use the scope, the ps3000a.dll is crashing inside ps3000aRunBlock API with message "Unhandled Exception at 0x.. in Appname.exe : C0000005: Access violation reading location 0x.....".

- The issue is random but often repeatable in once in 10 times.
- The crash happens the first time or during subsequent usage.
- It happens in both release and debug builds.
- I have verified the inputs and other settings to this API is exactly the same during working & non-working scenario.

To repeat the problem, I created a small application that will :
Repeat following steps in a loop {initialize - start scope - stop - close unit}.
A 200ms delay is added in between each step.

Attached are the error screenshots of error and simplified pseudo code to repeat the problem.

I appreciate any suggestion to narrow down this pico scope dll crash issue .
Please let me know if you need any other specific information.

Regards
Ink
Attachments
Crash_Report_4226_appcompat.txt
(9.19 KiB) Downloaded 75 times
pseudo_code_pico_crash_issue.c
(3.25 KiB) Downloaded 68 times
Error_Screenshots.zip
(499.29 KiB) Downloaded 38 times

Inka
Newbie
Posts: 0
Joined: Tue Apr 16, 2019 3:07 am

Re: Picoscope 3403D library - ps3000a.dll crashes inside ps3000aRunBlock API

Post by Inka » Mon Apr 29, 2019 2:19 am

Any suggestion or direction much appreciated.

Regards
Ink

Inka
Newbie
Posts: 0
Joined: Tue Apr 16, 2019 3:07 am

Re: Picoscope 3403D library - ps3000a.dll crashes inside ps3000aRunBlock API

Post by Inka » Tue May 28, 2019 7:08 am

Reference for other users who may face a similar issue in the future.

The observations are likely due to Library / Driver compatibility issues.
When Picoscope6 is installed along with Pico SDK, it will cause some mismatch leading to random crashes.

So I will keep only the SDK when running my application.

Hope this helps
Ink

Post Reply