ps3000aGetTimebase() outputs Invalid Handle error

Post discussions on applications you are writing
Post Reply
spflanze
User
User
Posts: 4
Joined: Wed Jul 11, 2018 11:36 pm

ps3000aGetTimebase() outputs Invalid Handle error

Post by spflanze » Thu Nov 01, 2018 3:33 am

ps3000aGetTimebase() outputs a PICO_STATUS value of 0x0C, which is an Invalid Handle error, in spite of the handle having been successfully used just prior to this call.

The VI in which the call to ps3000aGetTimebase() is called is attached. I have also attached the VIs that use this VI.

The VI that calls ps3000aGetTimebase() is "ps3000 Sample Rate to TImebase.vi"
The VI that calls "ps3000 Sample Rate to TImebase.vi" within which there is prior successful handle use is "PicoScope3000a Channel & Trig Settings.vi".
These were created in LabVIEW 2017.
Attachments
PicoScope3000a Channel & Trig Settings.vi
The VI that calls ps3000 Sample Rate to TImebase.vi and where the handle is successfully used just prior.
(54.85 KiB) Downloaded 49 times
PicoTech Error Handler.vi
Used by both the other two VIs.
(40.52 KiB) Downloaded 46 times
ps3000 Sample Rate to TImebase.vi
The VI that calls ps3000aGetTimebase() and where the error occurs.
(32.25 KiB) Downloaded 48 times

spflanze
User
User
Posts: 4
Joined: Wed Jul 11, 2018 11:36 pm

Re: ps3000aGetTimebase() outputs Invalid Handle error

Post by spflanze » Fri Nov 02, 2018 12:38 am

This problem is solved. In the LabVIEW call to ps3000aGetTimebase() the handle was set to pass by pointer. This must be set to pass by value. Once set to pass by value there was no error produced.

Post Reply