Running Picoscope on Raspbian x86_64

Discussion forum for the new Picoscope Linux software
Post Reply
lyapunov
Newbie
Posts: 0
Joined: Fri Jun 08, 2018 7:06 pm

Running Picoscope on Raspbian x86_64

Post by lyapunov » Thu Oct 18, 2018 5:37 pm

Hi!
I have an old iMac dedicated to running PicoScope. I run the x86_64 version of Raspian on here. It is basically Debian but with the Raspberry Pi GUI/Windows Manager which is a lot faster than the bloated distributions such as Ubuntu, et al.

I installed the Picoscope software on here in the past (after spending hours trying to get it working on Mac OS X) and everything worked wonderful.

Yesterday I reinstalled the OS and attmpted to reinstall PicoScope. I am no longer able to install it. The error I get is below:

Code: Select all

root@picohost:/home/pi/Downloads/tmp# apt-get install picoscope
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 picoscope : Depends: picomono (>= 4.6.2.16-1r02) but it is not installable
             Depends: libpicoipp (= 1.3.0-4r21) but it is not installable
             Depends: libpl1000 (= 2.0.0-1r570) but it is not installable
             Depends: libps2000 (= 3.0.0-3r570) but it is not installable
             Depends: libps2000a (= 2.1.0-5r570) but it is not installable
             Depends: libps3000 (= 4.0.0-3r570) but it is not installable
             Depends: libps3000a (= 2.1.0-6r570) but it is not installable
             Depends: libps4000 (= 2.1.0-2r570) but it is not installable
             Depends: libps4000a (= 2.1.0-2r570) but it is not installable
             Depends: libps5000 (= 2.1.0-3r570) but it is not installable
             Depends: libps5000a (= 2.1.0-5r570) but it is not installable
             Depends: libps6000 (= 2.1.0-6r580) but it is not installable
             Depends: libusbdrdaq (= 2.0.0-1r570) but it is not installable
E: Unable to correct problems, you have held broken packages.
Please help! This is causing a work stoppage!

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Running Picoscope on Raspbian x86_64

Post by Hitesh » Mon Oct 22, 2018 1:09 pm

Hi lyapunov,

The PicoScope software is not supported on Raspbian at this moment in time.

Are you able to install packages individually e.g.

Code: Select all

sudo apt-get install libps3000a
Regards,
Hitesh

Software Dev. Engineer

Post Reply