Returning from suspend without having to restart Picoscope ?

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
nurber
User
User
Posts: 7
Joined: Fri Mar 24, 2017 6:05 pm

Returning from suspend without having to restart Picoscope ?

Post by nurber » Fri Oct 12, 2018 10:10 pm

Hi Forum. I often will suspend Windows ( power button or closing clamshell of notebook ) with Picoscope still connected although not running. When I return from suspend I'm greeted with "Not Responding" caption in Picoscope and forced to restart the app. When I do restart there is sometimes an additional delay before 4444 is seen ( as compared to running for first time in a session where detection seems quicker ). Is this a configuration issue or something I need to live with ?

Sven

Martyn
Site Admin
Site Admin
Posts: 3656
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Returning from suspend without having to restart Picoscope ?

Post by Martyn » Thu Oct 18, 2018 9:31 am

There will be settings related to the USB bus on your PC, and what happens to it when in suspend mode, that may make some difference. However as you are probably trying to save power living with the delays would probably be best.
Martyn
Technical Support Manager

nurber
User
User
Posts: 7
Joined: Fri Mar 24, 2017 6:05 pm

Re: Returning from suspend without having to restart Picoscope ?

Post by nurber » Tue Oct 23, 2018 10:26 pm

FWIW, for the first time an error report was generated when returning from sleeping notebook. Is such a report useful ? If so, where do I send ?

Martyn
Site Admin
Site Admin
Posts: 3656
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Returning from suspend without having to restart Picoscope ?

Post by Martyn » Wed Oct 24, 2018 5:21 am

If you have the trace.xml file then yes send it to support@picotech.com
Martyn
Technical Support Manager

nurber
User
User
Posts: 7
Joined: Fri Mar 24, 2017 6:05 pm

Re: Returning from suspend without having to restart Picoscope ?

Post by nurber » Thu Sep 12, 2019 12:56 am

new laptop, same problem. If laptop goes to sleep, 4444 cannot resume without having USB cord unplugged. The red LED on 4444 stays on until USB cord reconnected. Would appreciate hearing if somebody with 4444 is able to return from sleep and what suggestions Picoscope has about the problem. Per Martyn's request I sent in trace.xml when requested, but never heard anything.

Frustrating. Sven

Post Reply