PicoSDK cannot find 5242D (python)

Post general discussions on using our drivers to write your own software here
Post Reply
cucook
Newbie
Posts: 0
Joined: Thu Sep 27, 2018 7:03 pm

PicoSDK cannot find 5242D (python)

Post by cucook » Thu Sep 27, 2018 7:27 pm

I'm attempting to access a 5242D MSO PicoScope via the picosdk-python-wrappers API. The API does not appear to be able to find the connected scope:

Code: Select all

(picosdk) C:\Users\cucoo>python
Python 3.7.0 (v3.7.0:1bf9cc5093, Jun 27 2018, 04:59:51) [MSC v.1914 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> from picosdk.ps5000a import ps5000a
>>> device = ps5000a.open_unit()
Traceback (most recent call last):
  File "", line 1, in 
  File "C:\Users\cucoo\picosdk\lib\site-packages\picosdk\library.py", line 179, in open_unit
    return Device(self, self._python_open_unit(serial=serial, resolution=resolution))
  File "C:\Users\cucoo\picosdk\lib\site-packages\picosdk\library.py", line 200, in _python_open_unit
    raise DeviceNotFoundError(message)
picosdk.library.DeviceNotFoundError: Driver ps5000a could find no devices (PICO_NOT_FOUND)
The scope is connected to the host via a USB 3 port. A red LED is displayed on the front panel. When the code listing above is run, the scope LED does not change, and the scope makes no noise. Identical behavior is observed when the same code listing is run with Python27. I have PicoSDK_64_10.6.12.41 installed.

The PicoScope 6 software, when opened on this same host, connects successfully to the scope; the front panel LED turns green, the scope clicks, and the scope works as expected.

Martyn
Site Admin
Site Admin
Posts: 3691
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoSDK cannot find 5242D (python)

Post by Martyn » Fri Sep 28, 2018 10:42 am

You will need to contact support@picotech.com to obtain the necessary files that provide support for the 5242D
Martyn
Technical Support Manager

ChrisDD
Newbie
Posts: 0
Joined: Wed Oct 10, 2018 1:04 pm

Re: PicoSDK cannot find 5242D (python)

Post by ChrisDD » Wed Oct 10, 2018 1:33 pm

I've got exactly the same problem with a 5442D. The connection with PicoScope 6 works correctly, but with Python 2.7 no connection can be established:

Code: Select all

In [1]:

from picosdk.discover import find_all_units
scopes = find_all_units()
for scope in scopes:
    print(scope.info)
    scope.close()

DeviceNotFoundErrorTraceback (most recent call last)
 in ()
      1 from picosdk.discover import find_all_units
      2 
----> 3 scopes = find_all_units()
      4 
      5 for scope in scopes:

C:\ProgramData\Anaconda2\lib\site-packages\picosdk\discover.pyc in find_all_units()
     47         devices.append(device)
     48     if not devices:
---> 49         raise DeviceNotFoundError("Could not find any devices on any drivers.")
     50     return devices
     51 

DeviceNotFoundError: Could not find any devices on any drivers.

Martyn
Site Admin
Site Admin
Posts: 3691
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoSDK cannot find 5242D (python)

Post by Martyn » Thu Oct 11, 2018 10:41 am

Have you contacted support for the appropriate support files ?
Martyn
Technical Support Manager

ChrisDD
Newbie
Posts: 0
Joined: Wed Oct 10, 2018 1:04 pm

Re: PicoSDK cannot find 5242D (python)

Post by ChrisDD » Thu Oct 11, 2018 11:25 am

Yes, I did. With the new SDK (10.6.13) the scope can be connected via Python. Thank you!

Post Reply