[Solved] DrDaq segfaults on open in Ubuntu 16.04

Look here for drivers, example code and projects using the DrDaq with Linux
Post Reply
Posts: 0
Joined: Mon Sep 12, 2016 12:45 pm

[Solved] DrDaq segfaults on open in Ubuntu 16.04

Post by tmkr »

Hello everyone,

whenever I try to open my DrDaq unit it just segfaults. It does so with Picoscope and with a custom written software:

Code: Select all

#include "usbDrDaqApi.h"

main(int argc, char *argv[])
  short hnd;

  stat = UsbDrDaqOpenUnit(&hnd);
This simply segfaults for me, and as I said above, if I try to start Picoscope with my DrDaq connected, it segfaults as well.
I get a "general protection" fault in "libusbdrdaq.so.2.0.0" in my kernel log for the custom software as well.

What am I missing?

Thanks in advance and kind regards!

Advanced User
Advanced User
Posts: 2856
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: [Solved] DrDaq segfaults on open in Ubuntu 16.04

Post by Hitesh »

Hi tmkr,

I have responded via your e-mail support ticket.

How did you resolve this?


Software Dev. Engineer

Post Reply