Search found 14 matches

by RTFM@1984
Thu Mar 05, 2020 9:53 am
Forum: PicoScope 6 for Linux
Topic: Importance of Linux as supported OS
Replies: 10
Views: 9978

Re: Importance of Linux as supported OS

I fully agree to what boris! expresses. The linux software is not on par with the windows counterpart. There are bugs in the linux software, having to do with the user interface and visualisation, both of which should be fixable with a few hours and I call "low hanging fruit". Still picotech is not ...
by RTFM@1984
Tue Dec 24, 2019 12:03 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope application is unusable on high-DPI screens
Replies: 6
Views: 5320

Re: PicoScope application is unusable on high-DPI screens

Same for me. I hope very much a major next release will fix this.
by RTFM@1984
Sun Sep 29, 2019 7:32 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

If you follow the symbolic link to picoscope and the script which is in: /opt/picoscope/bin/picoscope can you find out if something is not working in the script? In my case, I can start it manually with: # assuming mono is located at: # $(which mono 2>/dev/null) # and equals to: # /opt/picomono/bin/...
by RTFM@1984
Sun Sep 29, 2019 6:52 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

picotech forum is not allowing me to reply with some bash output. What is the purpose of this forum at all? I wanted to say that you can check your locale in linux. Mine is the following: $ locale LANG=en_US.UTF-8 LANGUAGE=en_US LC_CTYPE="en_US.UTF-8" LC_NUMERIC=en_GB.UTF-8 LC_TIME=de_DE.UTF-8 LC_CO...
by RTFM@1984
Tue Sep 24, 2019 9:14 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

Could you try to find out with strace which file access attempt, if any, is causing a problem?
by RTFM@1984
Tue Sep 24, 2019 6:59 am
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

Are you able to start picoscope in demo mode, i.e. without a device connected?
by RTFM@1984
Tue Sep 24, 2019 6:52 am
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

Is the symbolic link to which libgdiplus refers to also present on your system?
by RTFM@1984
Sun Sep 22, 2019 1:24 pm
Forum: PicoScope 6 for Linux
Topic: Bit Resolution Enhancement not persistent
Replies: 3
Views: 4804

Re: Bit Resolution Enhancement not persistent

The clarify further, on Ubuntu 18.04 with 6.13.7.707 settings do persist but in the configuration settings for channel A settings are always reverted to the default state when reopening that window.
by RTFM@1984
Sun Sep 22, 2019 1:22 pm
Forum: PicoScope 6 for Linux
Topic: Channel overrange on SW version 6.13.7.707
Replies: 3
Views: 4724

Re: Channel overrange on SW version 6.13.7.707

I have tried further: Above and including "100 s/div" picoscope cannot show the signal properly. Faster speeds (50 s/div and faster) work without issues. Steps to reproduce: 1. Add power supply to the picoscope (6402D) 2. Connect a 12v battery to Channel 1. (+ to CH.1 and - to shield) 3. Start picos...
by RTFM@1984
Sun Sep 22, 2019 12:36 pm
Forum: PicoScope 6 for Linux
Topic: PicoScope 6 crashes at startup on Ubuntu 18.04
Replies: 14
Views: 9711

Re: PicoScope 6 crashes at startup on Ubuntu 18.04

In the xml file it says: Inner Exception:System.DllNotFoundException: /opt/picomono/lib/libgdiplus.so I have the same version and the same Ubuntu 18.04 and it works fine in my case. Can you do an ls of /opt/picomono/lib/ You should see something like: $ls -al /opt/picomono/lib total 39380 drwxr-xr-x...
by RTFM@1984
Wed Sep 04, 2019 6:51 am
Forum: PicoScope 6 for Linux
Topic: Channel overrange on SW version 6.13.7.707
Replies: 3
Views: 4724

Re: Channel overrange on SW version 6.13.7.707

> Do you get the same overrange indication at 1s/div, where the trace will still be streaming ? I will need to try, at which speed it start to happen. > If you leave it running at 5000s/div does the trace become reasonable after a few minutes ? No it does not. I waited at least more than 10 minutes ...
by RTFM@1984
Wed Sep 04, 2019 6:47 am
Forum: PicoScope 6 for Linux
Topic: Bit Resolution Enhancement not persistent
Replies: 3
Views: 4804

Re: Bit Resolution Enhancement not persistent

It is operating in 12 bit, but it does not show it as such. Furthermore, once opening the window for a second time, it jumps back to 8 bit. This means settings needs to be set again. The persistency problem not only applies to the bit resolution enhancement, but also to other settings like bandwidth...
by RTFM@1984
Fri Aug 30, 2019 10:51 am
Forum: PicoScope 6 for Linux
Topic: Bit Resolution Enhancement not persistent
Replies: 3
Views: 4804

Bit Resolution Enhancement not persistent

When changing the Bit Resolution Enhancement setting with software version 6.13.7 from the default 8.0 bits to 12.0 bits (or any other resolution), the new setting is executed when changed and kept when the small window is closed. But when again clicking on the Channel Options for "A", the resolutio...
by RTFM@1984
Thu Aug 29, 2019 10:04 pm
Forum: PicoScope 6 for Linux
Topic: Channel overrange on SW version 6.13.7.707
Replies: 3
Views: 4724

Channel overrange on SW version 6.13.7.707

I am trying to measure the capacity of a battery pack by discharging it with a known resistor. For this I set a very large time/div (5000s/div) in order to able to capture about 10 hours. Unfortunately the software is unable to capture a voltage at such a large time/div setting. With shorter time/di...