Search found 30 matches

by Bob Mehew
Tue Feb 11, 2020 12:04 pm
Forum: PicoScope 6 for Windows
Topic: Saving part of a waveform
Replies: 2
Views: 1522

Re: Saving part of a waveform

I look forward with hope then, but for the time being back to Excel
by Bob Mehew
Mon Feb 10, 2020 9:14 pm
Forum: PicoScope 6 for Windows
Topic: Saving part of a waveform
Replies: 2
Views: 1522

Saving part of a waveform

Is there a means by which one can save just part of a waveform, say that between the rulers? I can do it heavy handedly by saving the whole as a csv file, taking it into Excel, plotting all the data and then focusing in on the part I am interested in. But it would be nice to have the flexibility to ...
by Bob Mehew
Fri Feb 01, 2019 5:02 pm
Forum: PicoScope 6 for Windows
Topic: Stop Go Buttons toggle action
Replies: 1
Views: 1104

Stop Go Buttons toggle action

I have just been using the Picoscope in wintry climes and discovered an unfortunate error mode. On trying to stop the scope from recording by using the screen Stop button, in the cold I inadvertently pressed the mouse button twice. I see that this act toggles the action between the Go and Stop butto...
by Bob Mehew
Thu Jan 25, 2018 12:14 pm
Forum: PicoScope 6 for Windows
Topic: variation in Data Set Length between saved files
Replies: 3
Views: 1819

Re: variation in Data Set Length between saved files

I am using software version: 6.12.9.2917 . I note one also sees some padding of the file if one records less than a full wave form and then tries to save it as a full wave form using the Save as / all wave forms command. I will send a file to you but it occurs what ever the data source. (I found out...
by Bob Mehew
Tue Jan 23, 2018 11:13 am
Forum: PicoScope 6 for Windows
Topic: variation in Data Set Length between saved files
Replies: 3
Views: 1819

variation in Data Set Length between saved files

I have just found that if I set Picosoft to a single trigger and run for just one page to collect a notional 1 Mega set of samples, when I save the data in the .mat format I get 1,000,000 samples but when I save the data in the .csv format I get 1,000,004 samples. Whilst I see Picosoft disclaims a p...
by Bob Mehew
Thu Jan 28, 2016 4:45 pm
Forum: USB PC Oscilloscopes
Topic: USB lead length problem
Replies: 2
Views: 2510

Re: USB lead length problem

I thought all USB cables were required by the spec to be shielded (indeed doubly so with copper braid plus aluminumised polyester foil). However, I thought the experience was worth posting as a 'cautionary tale'.
by Bob Mehew
Wed Jan 20, 2016 10:27 pm
Forum: USB PC Oscilloscopes
Topic: USB lead length problem
Replies: 2
Views: 2510

USB lead length problem

Just had a dreadful day when I thought my Pico 4424 was broken. I went out to do some work in an unheated environment and realized I had forgotten to take the supplied USB lead with me. So I found a 0.63m long one and plugged that in. With no BNC connector plugged in, the notional zero read +15mV on...
by Bob Mehew
Fri Feb 20, 2015 3:02 pm
Forum: PicoScope 6 for Windows
Topic: # samples when going from .psdata to .mat
Replies: 13
Views: 6412

Re: # samples when going from .psdata to .mat

The simple work around is to always use the trigger function in single shot mode so the data ends at end of screen. That way the conversion from .psdata to .mat works and we can read all channels OK. However from time to time, we like to use PicoSoft in continuous display mode which gives rise to ou...
by Bob Mehew
Mon Feb 16, 2015 2:00 pm
Forum: PicoScope 6 for Windows
Topic: # samples when going from .psdata to .mat
Replies: 13
Views: 6412

Re: # samples when going from .psdata to .mat

Hi

has this bug been dealt with yet? I still seem to have the same problem in v6.10.11.15. It would be nice to work directly rather than having to separately record and then stitch back together the data.

Bob
by Bob Mehew
Fri Apr 25, 2014 2:53 pm
Forum: PicoScope 6 for Windows
Topic: # samples when going from .psdata to .mat
Replies: 13
Views: 6412

Re: # samples when going from .psdata to .mat

Ah, I had not appreciated that channel hide had that power. I must save data before looking at it to avoid that problem / benefit. Thanks for the info.
by Bob Mehew
Wed Apr 23, 2014 3:10 pm
Forum: PicoScope 6 for Windows
Topic: # samples when going from .psdata to .mat
Replies: 13
Views: 6412

Re: # samples when going from .psdata to .mat

The file is too large to attach so I will send it. I presume when you say "The workaround is to load in only channel A into MATLAB, and then export only channel B to .mat file." you are not referring to using the Picosoft 'save as' function. Our process is having recorded the data and saved it as a ...
by Bob Mehew
Wed Apr 23, 2014 8:42 am
Forum: PicoScope 6 for Windows
Topic: # samples when going from .psdata to .mat
Replies: 13
Views: 6412

Re: # samples when going from .psdata to .mat

Hi just came across this bug from another direction. I normally save my 2 channels worth of data to psdata file format and subsequently transform it to a mat file format for onward processing. Usually my 2 channels of data is collected using the single trigger mode, so I collect one full buffer memo...
by Bob Mehew
Fri Dec 20, 2013 7:39 pm
Forum: PicoScope 6 for Windows
Topic: Gap in continuous data
Replies: 13
Views: 12941

Re: Gap in continuous data

Having also found this phenomena and identified a work around, one additional minor point still irritates me. The Properties pane shows summary data in use including a value for the number of samples per waveform. Tests with a 4424 and a 4224 and several software versions (6.6 & 6.7) show that the a...
by Bob Mehew
Thu Jul 04, 2013 12:00 pm
Forum: PicoScope 5
Topic: adc1032.dll
Replies: 4
Views: 7975

Re: adc1032.dll

many thanks for the advice which worked!
by Bob Mehew
Wed Jul 03, 2013 4:49 pm
Forum: PicoScope 5
Topic: adc1032.dll
Replies: 4
Views: 7975

Re: adc1032.dll

I am running a 32bit machine using Windows XP plus SP3. I ticked the box but got no option to select a second device. It just went straight on to load the software. I uninstalled 5.20.8 and tried installing 5.21.2 but all that happened was the installed ran through to some point and then rolled back...